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_____________________________________________________________________

  GammaCAD is a full featured CAD (Computer Aided Design) program for
  Windows.  It provides a wide range of functionality in an easy to 
  use package.

  GammaCAD allows you to create drawings of real world objects in 
  two dimensions using their actual measurements.  They can then
  be plotted at any scale you choose on any of the vast number of   
  printers and plotters supported by Windows.  The biggest advantage
  of using a computer to create these drawings over conventional
  hand methods is the ease with which a computer based drawing can
  be edited and replotted at different scales.

  CAD is used in many fields including: architecture, cartography,
  electronics and engineering.  It can be used to create house plans,
  maps of all kinds, printed circuit diagrams, and any kind of graph,
  chart, diagram or illustration.

  This program allows you to create drawings using 5 basic drawing
  elements.  These elements are: lines, arcs, circles, points and
  text.  You may enter exact coordinates for these elements, pick a
  position on the display or "snap" to a position on another element
  in the drawing.  For example, you can draw a line which starts
  exactly at the end of an existing line.

  GammaCAD also has predefined symbols you can place in your drawing 
  for such things as floor plans, furniture, polygons, electronics, 
  landscaping, computer equipment and civil engineering.
  
  Once these basic drawing elements are in your drawing you can edit
  them to your liking.  They can be edited individually or as a
  group.  The elements can be deleted, copied, scaled, rotated and 
  their properties can be changed.  These operations can be undone.
  This allows you to experiment with the drawing.

  Many properties of the drawing elements can be specified.  The line
  type (e.g. solid, dashed, dotted, etc.), line color and line width
  can be specified.  Text properties include: font, size, color,
  angle and justification.  Point type, color and size can also be
  set.

  The drawing can be zoomed and panned to look at different parts in
  more detail.  Zoom functions include: window, extents, previous
  and factor.

  The drawings you create in GammaCAD can be copied to the Windows
  clipboard as a bitmap and pasted into your favorite word processor,
  paint program or any program which lets you paste a bitmap.  This
  means you can place technical drawings in your documents.

  GammaCAD is designed to be powerful and easy to use.  The program 
  contains on-line help to get you up and running as quickly as 
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  possible.  A prompt area is displayed at the bottom of the window 
  which instructs you how to perform each command.  A status area 
  displays pertinent program information at a glance.  The program 
  also employs easy to use visual dialog boxes.

  Gamma Software is committed to providing you with quality software
  at affordable prices.

  About This Manual
  Read the "Getting Started" section first.  The rest of the manual
  can be read as needed to get more information on a particular   
  subject.

  Getting Help
  If you have a problem with this program and cannot find the answer
  in the documentation help may be obtained by calling:

     (303) 490-2928  voice/fax (start fax immediately after dialing)

  or via E-mail at:

     Compuserve: 73737,1721
     GEnie:      T.EMMER
     Internet:   73737.1721@compuserve.com

  or by writing to:
  
     Gamma Software
     P.O. Box 8191
     Fort Collins, CO 80526
     U.S.A.

  Please describe the problem in sufficient detail so it can be
  reproduced by us.

  We are open 8am-5pm Mountain time (Mon-Fri) excluding holidays.

  Support is currently free and unlimited.  We do reserve the right
  to change these policies in the future.
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  System Requirements
    - Windows 3.1 and a system capable of running it:
       - Personal computer (286 or better).
       - 640K conventional memory and at least 256K extended memory.
       - DOS 3.1 or later.
       - Windows supported display.
    - Hard disk with at least 650K of free disk space.
    - Floppy drive (if installing from floppy disk).
    - A Windows supported printer, mouse and color display are
      highly recommended.
    Note - this program will NOT work with Windows 3.0 or previous 
    versions of Windows.

  Manual Conventions
  When two keys need to be pressed simultaneously to perform a given
  operation they are separated by a plus (+).  For example, Shift+Tab
  means to press the Shift key and hold it down while the Tab key is
  pressed.  When a menu option or other text from the program is   
  mentioned it is enclosed in quotes.  Values which must be input by
  the user are enclosed in quotes as well.  Enter them without the
  quotes.  For example, if the manual instructs you to enter "45" in
  a field within the program enter the number without the quote
  marks.
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  This section will take you on a brief guided tour of the program
  and demonstrate how to use some of its main features.  It is    
  assumed you are familiar with Windows.  If you are new to Windows 
  you should read the getting started section of the Windows manual 
  first.  If you are already familiar with CAD you can probably skip 
  this section.  It is also assumed you have already installed 
  GammaCAD and executed the program and you are currently at the main
  program window, below.

      +---------------------------------------------------+
      |                    GammaCAD                       |
      +---------------------------------------------------+
      |             Main or Pull Down Menu                |
      +----------------------------------------+----------+
      |   y                                    |          |
      |                                        |          |
      |   ^         Drawing Area               |  Status  |
      |   |                                    |   Area   |
      |   +--> x                               |          |
      |(0,0)                                   |          |
      +----------------------------------------+----------+
      |                  Prompt Area                      |
      +---------------------------------------------------+

                       Figure 1 - Main Window

  When you first enter GammaCAD you are placed in a new "Untitled"
  drawing.  This program uses a standard 2 dimensional xy coordinate
  system.  Positions are specified by giving their x and y value.
  These positions are indicated by 2 values within parentheses in 
  this manual.  For example, (2,3) indicates an x position of 2 and a
  y position of 3.  The origin of this coordinate system (0,0) is 
  initially placed in the lower-left of the drawing area.  The x axis
  starts at the origin and increases to the right.  The y axis starts
  at the origin and increases upward.  The first 2 fields in the 
  status area indicate the current xy position of the cursor within 
  the drawing area.  When the cursor is within the drawing area it is
  displayed as a small cross.  It can be moved using the mouse or the
  keyboard arrow keys.  These xy positions can be in any units and 
  are referred to as "drawing units" in this program.  They are 
  related to actual sizes using the plot scale (more on this later).
  Move the cursor around the drawing area and watch how the xy 
  position in the status area changes to get a feel for the 
  coordinate system.

  The initial drawing is blank, this means it contains no drawing 
  elements.  To draw elements within the drawing area you simply
  select "Draw" from the pull down menu and select one of the
  options on this menu.  For example, to draw a line starting at the 
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  position (1,1) select "Line" from the "Draw" menu.  The prompt area
  will display:

     Select first end point of line
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  The first line of the prompt area tells you what the program is
  currently looking for.  In this case it is asking you to enter the
  first point of a line.  The second line of the prompt area tells
  you how to accomplish this using the mouse.  The third line tells
  you how to accomplish the task using the keyboard.  This same
  format for the prompt area is used throughout the program.  The
  first line tells you what the program wants, the second line tells
  you how to do it with the mouse and the third line tells you how
  to do it with the keyboard.

  Getting back to what we set out to do -- draw a line starting at  
  (1,1) -- click the right mouse button or press the F2 key.  This
  brings up a coordinate input dialog box.  You are initially placed
  in the x value field.  Enter "1" in this field.  Now press Tab or 
  click on the Y-coordinate field.  Then enter "1" in that field.
  Press Enter or click on the "OK" button.  The position (1,1) has 
  now been specified for the first end of the line.

  The first line of the prompt area has now changed to prompt us for
  the second end point of the line.  You do not have to specify
  exact coordinates for drawing elements.  You can also simply pick 
  them within the drawing area.  To do this move the cursor using
  the mouse or arrow keys to any position within the drawing area.
  As you move the cursor a line is drawn from the first point you
  selected to the current cursor position.  This represents the line
  which will be drawn if the current cursor location is selected.  
  When you have positioned the cursor where you want it, click the 
  left mouse button or press Enter.  We have now successfully drawn 
  a line.  You may continue to draw another line starting at the 
  end of the previous one or you can draw another element.

  To draw an arc select "Arc" from the "Draw" menu.  Arcs must
  always be drawn in a counter-clockwise direction by entering the
  first end point, then the center and finally the second end point.
  For example, lets draw an arc starting at (5,1), has a center   
  point of (3,1) and an end point of (1,1).  To do this, click the 
  right mouse button or press F2.  Next, enter the coordinates (5,1) 
  in the dialog box the same way you did for the first line end point
  in the previous step.  Repeat this procedure to enter the center
  point of the arc at (3,1).  Now move the cursor and as you do so
  an arc is drawn using the previously specified end and center
  points and the current cursor position as the last end point.  This
  represents the arc which would be drawn if the current cursor
  position is used for the last end point.  Select the position 
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  (1,1) for the last end point as before (click the right mouse
  button or press F2 and enter the coordinates in the dialog).  You 
  have now drawn an arc.  You can continue drawing more arcs by 
  entering their start, center and end points or select another 
  drawing element.

  To draw a circle you follow the same kind of procedure as for
  lines and arcs.  Select "Circle" from the "Draw" menu.  Select a 
  position for the center of the circle.  A circle is then drawn
  with the given center and through the current cursor position.
  Select a position on the circle and the circle is added to the
  drawing.

  To draw points select "Point" from the "Draw" menu and then select
  a position for the point.  A point is added to the drawing at the
  given position.

  To draw text select "Text" from the "Draw" menu and enter the text
  alignment point.  This is the upper-left corner of the text string.
  After selecting the alignment point a dialog box is displayed to 
  allow you to enter a text string.  Type in the desired text string 
  and click on the "OK" button or press Enter.  The given text is
  added to the drawing at the specified position.

  Experiment with these drawing commands until you feel comfortable
  with them.

  As we have seen selecting another command from the "Draw" menu
  ends the previous one.  Selecting anything from the main menu    
  except "Options" will end a drawing command.  The reason "Options" 
  does not end the current drawing command is so you can change
  the properties of whatever you are drawing without having to
  reselect the drawing command (more on this in a moment).  There is
  also another way to end a drawing command.  Click the right mouse
  button or press F2 while a drawing command is prompting you for a
  position and select the "End" button from the coordinate input 
  dialog.  For example, select "Line" from the "Draw" menu.  Now
  click the right mouse button or press F2.  Next select the "End" 
  button.  This will end the line command and clear the prompt area.
  The "Cancel" button on the coordinate input menu cancels manual
  input of the coordinates and allows you to go back to selecting 
  them with the cursor, it does not end the command.

  We have now covered all of the drawing elements you can create
  with this program.  Next we will cover some ways of changing the 
  look of these drawing elements.  The "Options" menu contains all
  of the properties you can specify for the drawing elements in the
  "Draw" menu.  Some general program parameters can be set using the
  "Options" menu as well.

  First lets look at the different kinds of lines we can draw. 
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  Select "Line Color" from the "Options" menu.  This brings up the
  color selection dialog.  Select one of the colors from this menu.
  Only solid colors can be specified.  This means if you select a 
  nonsolid color it will be mapped to the closest solid color.  See 
  your Windows manual for more information on colors.  
  
  After entering a color select "Line" from the "Draw" menu and pick
  2 points within the drawing area.  A line will be drawn in the 
  selected color between the 2 given points.
  
  You can change line properties in the middle of drawing lines 
  without ending the line command.  For example, select "Line Type" 
  from the "Options" menu.  This brings up the line type dialog.  
  Click on the "Dash" line type.  The "Dash" radio button will be
  marked and the previously marked line type is unmarked.  Now click 
  on the "OK" button or press Enter.  Now select the second end point
  of a line (the first will be the end of your previous line).  The 
  line will be drawn using your selected color and line type.

  The last line property is width.  Select "Line Width" from the
  "Options" menu and enter "0.2" for the line width.  The width
  is specified in drawing units.  Now enter the second end point of 
  another line.  The line width hasn't changed, has it?  This
  demonstrates an important point.  Only solid lines can have a
  width greater than 1 pixel.  Select the solid line type from the
  options menu and enter the second end point of another line.  This
  time the line will be wider.
  
  Line properties affect not only lines but arcs and circles as well.
  Draw a few arcs and circles to see how your current line property
  settings affect them.
  
  The main property of a text element is its font.  With Windows
  3.1 TrueType fonts were introduced.  These fonts work best in this
  program and are recommended over previous Windows fonts.  When
  there is a check mark to the left of the "TrueType Fonts Only"
  selection in the "Options" menu, the "Text Font" selection below it
  will list only TrueType fonts.  To access other fonts click on the 
  "TrueType Fonts Only" selection.  The check mark will be removed 
  and all fonts will be listed in font selection.

  Now select "Text Font" from the "Options" menu.  This brings up
  the font selection dialog.  With this dialog you specify the 
  font name, style, size, color and effects.  Sizes are in points.
  A point is 1/72 of an inch.  The point size selected is the size
  you want the text to appear on paper when the drawing is plotted.
  The size of the text on your display will vary depending on the 
  plot scale you have specified and the current extents of the
  drawing area.  Once you have selected a font from this menu, draw 
  a text string as you did previously to see the font you have 
  selected.  Experiment with the different font parameters in the
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  font selection dialog until you get a feel for what each one does.
  
  Text may be placed at an angle using the "Text Angle" selection on
  the "Options" menu.  This angle is measured counter-clockwise from
  the x axis in degrees.  First select the "Arial" font using the
  "Text Font" selection on the options menu.  Next select "Text
  Angle" from the "Options" menu.  Enter "45" for the text angle.  
  Now draw a text string.  Its baseline will be at a 45 degree angle.

  Text orientation specifies the rotation of individual characters
  within a text string.  It has no affect on TrueType fonts so this 
  menu selection is dimmed if "TrueType Fonts Only" is checked.
  Only Windows vector fonts (e.g. Roman, Script and Modern) support
  orientation angles.  See the "Setting Text Properties" section for 
  more information on how to use orientation angles.

  To change the alignment point of a text string from the upper-left
  to another position within the string, use the "Text Justification"
  item on the "Options" pull down.  For example, if you want to
  specify a text alignment point representing the lower right end of 
  a text string, select the "Text Justification" option and set 
  "Right" and "Bottom" as the text alignment.  Now when you draw
  text, the alignment point you pick will specify the right bottom
  position of the text string.

  Point properties can be entered in much the same way as line and
  text properties.  Experiment with changing these properties and
  drawing points to see the effects.

  At this point we should do something which should always be done
  periodically when creating a drawing, save it to disk.  This will 
  prevent losing your drawing in case of a power failure, system 
  crash or similar catastrophe.  To save this file select "Save As" 
  from the "File" menu.  This will bring up the Windows file 
  selection dialog.  Enter "TEST" in the "File Name" field and click 
  on the "OK" button.  The drawing will be saved to TEST.GC1 in the 
  directory shown and can be retrieved later using the "Open" option 
  on the "File" menu.
  
  To produce a printed or plotted output of a drawing you use the
  "Print/Plot" option on the "File" menu.  First select "Open" off 
  the "File" menu and select the file SAMPLE.GC1 supplied with the 
  program.  This drawing shows the top, right and front views of a
  flange.  Next select "Print/Plot" from the "File" menu.  This will 
  bring up the plot scale dialog.  Enter a scale of "2" (1 inch = 2 
  drawing units) and click on the "OK" button.  Select the desired 
  print parameters from the Print Setup dialog and click on "OK".

  The current coordinates of the lower left of the drawing area will
  be used as the lower-left of the plot.  As much of the drawing as 
  can be displayed using the given scale will be plotted to the 
  current print device.  If you do not care about the scale and 
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  simply want to plot the current view as large as possible click on 
  the "Fit plot to page" check box in the scale dialog.  The plot 
  scale is ignored for these type plots.

  Now lets look at some of the "View" menu options.  These allow you
  to look at your drawing in more or less detail.    For example, to 
  look at the top view in more detail select "Zoom Window" from the 
  "View" menu.  The program will prompt for the first corner of the 
  window.  Pick a point just below and to the left of the top view.  
  Next the program will prompt for the second point defining the 
  window.  As you move the cursor a box is displayed with one corner 
  on the first point you selected and the other at the current cursor
  position.  This box represents the window.  Move the cursor to a 
  point above and to the right of the top view so the whole top view 
  is enclosed in the box and press the left mouse button.  The 
  program will then display the area you selected using the entire 
  drawing area.                                             

  The right and front views are no longer visible.  To make sure all 
  the elements in the drawing are visible use the "Zoom Extents" 
  option.  Select "Zoom Extents" form the "View" menu.  The drawing
  area window is adjusted so all drawing elements are visible and as 
  large as possible.

  To return to the previous view select "Zoom Previous" from the
  "View" menu.  Select this option.

  If you want to shift what is currently displayed in the drawing
  area to see other parts of the drawing you use the "Pan" command.  
  Select this option and pick a point near the bottom center of the 
  top view.  Next, pick a point directly above the previous point
  and near the top of the drawing area.  The drawing is then shifted
  up within the drawing area.

  The view commands simply change how the drawing elements are     
  displayed.  They do not change their coordinates or dimensions.
  To change the drawing element coordinates or dimensions use the
  "Edit" commands.

  The last things we need to look at in this overview of the program
  are the "Edit" functions.  First let's move the top view to 
  another position in the drawing.  Select "Zoom Extents" from the 
  "View" menu so the entire drawing is visible.  Then pick "Select" 
  from the "Edit" menu and pick a point below and to the left of the 
  top view for the first point.  Pick a point above and to the right 
  for the second point so the entire top view is within the 
  rectangle.  All the drawing elements which are within or cross the 
  selection area are selected.  They are displayed in the selection 
  color (initially light gray).  Now select "Cut" from the "Edit" 
  menu.  The program then prompts for a reference point.  Pick a 
  point near the middle of the top view.  The top view is then 
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  erased.  To move it to another position select "Paste" from the 
  "Edit" menu.  The program then prompts for the alignment point.  
  This point will be the new position of the reference point you 
  specified in the cut operation.  Pick a point more to the right of 
  the reference point you selected.  The top view will be redrawn at 
  this new position.  You can continue to select other alignment 
  points and insert multiple copies of the top view in your drawing.
  The "Copy" option does much the same as "Cut" except it does not 
  delete the original copy of the selected elements.  The "Cut" and 
  "Copy" options are the only ones which set the elements for the 
  "Paste" operation.  None of the other "Edit" options affect what is
  pasted during the "Paste" option.

  To simply delete unwanted elements in the drawing you use the
  "Delete" option.  This option does not allow you to paste the 
  deleted elements back into the drawing.  However, you can recover 
  them by selecting "Undo".  For example, "Select" the drawing 
  elements in the top view as you did before.  Next select "Delete" 
  from the "Edit" menu.  The elements will be erased from the display
  area and deleted from the drawing.  Now select "Undo" from the 
  "Edit" menu and the previously deleted elements will be redrawn and
  placed back in the drawing.
  
  To change the angle of elements within the drawing, you use the 
  "Rotate" command.  Select the top view as you did previously. 
  Then select "Rotate" and pick a position near the center of the
  selected top view as the center of rotation.  A dialog to enter the
  rotation angle will appear.  Enter "45" and press Enter.  The 
  top view will be rotated 45 degrees counter-clockwise.

  The "Scale" option functions much the same as rotate except 
  it is used to make the current element selection larger or smaller.
  For example, select "Scale" and pick a point near the center of the
  top view which you selected in the last step.  Enter a scale factor
  of "0.5" in the dialog box.  The selected top view will be drawn at
  half its original size.
  
  The "Change" item on the "Edit" menu allows you to change drawing
  element properties.  For example, select "Change" and pick "Line 
  Color" from the change dialog.  This will bring up the color 
  selection dialog.  Pick a new color from this menu.  In order to 
  see the color change you must select "Clear Selection" from the 
  "Edit" menu.  The current selection is always drawn in the 
  selection color.  The current selection is only changed when a new 
  selection is made or the selection is cleared.

  Finally, for on-line help with the features in this program select
  "Help" from the "Help" menu.  This brings up the Windows help
  facility.  For more information on how to use this facility look
  in your Windows manual.
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  This concludes your guided tour of the program.  Hopefully you will
  have enough information at this point to get started with your
  first drawing.  You can look at the other sections of this manual
  as needed to get more details on specific areas.
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  Parts Of The Program Window
  The figure below shows the different areas within the program
  window.  These will be referred to throughout this manual.

                       Figure 1 - Main Window

  The main or pull down menu contains the program commands.

  The prompt area displays what the program currently wants you to 
  enter and how to do it.

  The status area displays the current cursor xy coordinates, the
  amount of memory available, the current element snap mode and the
  number of fonts defined in the drawing.  The format of the xy 
  positions is affected by the international settings in the Windows 
  Control Panel (see "International Number Formats" below).

  The drawing area is where drawing elements are displayed and
  drawn.

  The title bar contains the program name and the current file name.

  The system menu contains the standard Windows system menu options.

  The min/max buttons minimize and maximize the program window.

  International Number Formats And Measurements / Number of Decimals
  This program utilizes the settings in the international section
  ("intl") of the Windows WIN.INI file.  These parameters can be
  configured using the "International" option in the Control Panel. 
  The "Decimal Separator" and "Decimal Digits" fields under "Number
  Format" are used by this program when formatting decimal numbers.
  Set the "Decimal Digits" field to the number of decimal places you
  want the program to display to the right of the decimal point.
  This causes the program to display that number of decimal places
  everywhere it displays a real number.

  The "Measurement" field determines whether the plot scale is
  specified in inches or centimeters.

  The Program Coordinate System
  This program uses a standard 2 dimensional cartesian coordinate 
  system.  This consists of 2 axes, x and y, which are perpendicular 
  to each other.  The x axis increases to the right and the y axis 
  increases upward.
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                  Figure 2 - XY Coordinate System

  Coordinates within this coordinate system are specified by giving
  their x and y distance from the origin.  These coordinates are
  denoted by x and y values in parentheses within this manual (x,y).

  For example, (10,20) designates a position 10 units to the right 
  (x distance) and 20 units up (y distance) from the origin.

                   Figure 3 - Coordinate Example

  The origin of this coordinate system is where the x and y axes
  intersect at coordinates (0,0).  When a new drawing is first 
  loaded, the origin is at the lower-left of the drawing area.  This 
  can change when any of the view options are selected.  The drawing 
  area can be thought of as a window which displays a portion of the 
  entire coordinate range.  Drawing elements which lie outside the 
  current window are not displayed but are still part of the drawing.

                   Figure 4 - Drawing Area Window

  The extents of the drawing are the minimum and maximum xy
  coordinates of all the drawing elements.  The drawing area extents
  are the lower-left and upper-right coordinates of the current
  drawing area.

                  Figure 5 - Drawing Area Extents

  The "X:" and "Y:" fields of the status area give you the current
  coordinates of the cursor within the drawing area.  The cursor is
  initially a small plus sign when it is within the drawing area.
  It can be moved with the mouse or keyboard arrow keys and the xy
  position in the status area will be updated as it is moved.

  The units the drawing area represents can be anything.  For 
  example, they can represent inches, feet, miles, millimeters, 
  meters, kilometers and so on.  The scale you enter when plotting
  specifies the relationship between the units in the drawing and
  the plot units (inches or centimeters).  

  Specifying Positions
  You need to specify positions for many of the options in this
  program.  A position is the (x,y) coordinates designating a  
  point in the drawing.

  There are three methods for specifying positions within this
  program:
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     1. Pick a position in the drawing area using the cursor.
     2. Enter exact coordinates (manual entry).
     3. Snap to an existing drawing element.

  The first method is the easiest.  All you have to do is position
  the cursor at the desired point in the drawing area using the
  mouse or keyboard arrow keys.  Then click the left mouse button

  or press Enter.  The disadvantage to using this method is you
1  cannot specify the exact coordinates of the point.  For example, if
  you wanted to pick a point at exactly (10,10) you could not do it
  using this method.  This is due to the fact the cursor moves in 
  steps.  This method is best used when you do not care about the 
  exact positions and dimensions of what you are drawing.

  The second method, manual entry, allows you to specify exact
  positions.  To use this method click the right mouse button or
  press F2 while the cursor is in the drawing area or select "Enter
  Coordinates" from the "Options" pull down menu.  This will bring
  up a "Coordinate Input" dialog.  You use this dialog to enter
  the exact (x,y) coordinates of a drawing position.  This method
  is used when you have the exact coordinates or dimensions of the 
  object you are drawing.

                 Figure 6 - Coordinate Input Dialog

  The third method, using element snaps, allows you to specify
  positions based on elements already in the drawing.  For example, 
  if you want a line to start at the exact same position as the end 
  of another line in your drawing, you would use the "End" element 
  snap.  To use element snaps, simply select the desired mode using 
  the "Element Snap" item on the "Options" pull down menu. 

                   Figure 7 - Element Snap Dialog

  You can select an element snap before or during a command.  The
  element snap selected remains in affect until another is chosen.
  The current element snap mode is displayed in the status area.  If 
  an element snap other than "NONE" is in affect, the cursor will 
  change from a cross to a box.  When a position is selected the 
  program will look to see if an element is within the box.  If one
  is the program will determine the proper coordinates from this
  element using the current snap mode.  The program tries to snap to 
  the first element it finds within the box.  If it cannot snap to 
  this element it uses the center of the box as the input point.  
  When you are using element snaps, you should make sure only one 

1  In reality you may be able to enter an exact coordinate using this
  method if one of the cursor steps just happens to fall on it, but 
  it is unlikely and in general you cannot enter exact coordinates
  using method 1.
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  element lies within the cursor box, so you are certain you are 
  snapping to the proper element.  Use the "Zoom Window" command to 
  enlarge the area around the element you are snapping to if 
  necessary to avoid getting other elements in your cursor box.

  For example, if the box cursor is placed as in the figure below and
  the current snap mode is set to "End," the program will use the 
  coordinates of the closest end of the line as input.

                    Figure 8 - Element Snap Pick

  In this case the program "snapped" to the top of the line and that
  point is used as the start of a new line as shown below.

                   Figure 9 - Element Snap Result

  The element snaps which are available within this program are:

     None   - no element snaps are used, the cursor is a cross.
     End    - snap to the end of the selected element.
     Center - snap to the center of an arc or circle element.
     Point  - snap to the position of a point element.

  The table below summarizes which element snap modes can be used
  for each drawing element.  If the element does not support a 
  particular snap mode, no snap position is determined and the 
  position of the center of the cursor box is used.

                           End  Center  Point
                   Line     X     X
                   Arc      X     X
                   Circle         X
                   Point                  X
                   Text

                      Table 1 - Element Snaps 

  The figure below demonstrates how the different snap modes can be
  used:

                     Figure 10 - Element Snaps
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  Lines
  Lines are drawn by entering their start and end points.

                       Figure 11 - Line Input

  To Draw a line all you have to do is select "Line" from the "Draw"
  pull down menu or you can press Ctrl+L.  The prompt area will 
  display:

     Select first end point of line
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  After entering the first end point, the first line of the prompt
  area changes to:

     Select second point

  As you move the cursor a line is drawn from the first point to the
  current cursor position which represents the line which would be
  added to the drawing if the current cursor position is used for the
  second end point.  When the second end point is specified, a line
  with the designated start and end points is added to the drawing.
  It is displayed using the current line properties in affect.

  The program continues to prompt you for a second point.  If you
  wish to draw another line which starts at the end of the previous
  one, you simply select the second end point of that line.

  To end line input, select another operation from the main menu 
  (except those on the "Options" menu).  You can also end line input
  by clicking the right mouse button (or press F2) and select "End" 
  from the dialog box which appears.

  See the section on "Specifying Positions" for more information on
  entering the line end points.  See the section on "Line Properties"
  for more information the different types of lines which can be
  drawn.

  Arcs
  Arcs are drawn by specifying their start, center and end points.
  They are always drawn in a counter-clockwise direction.

                       Figure 12 - Arc Input

  To Draw an arc all you have to do is select "Arc" from the "Draw"
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  pull down menu or you can press Ctrl+A.  The prompt area will 
  display:

     Select first end point of arc
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  After entering the first end point the first line of the prompt
  area changes to:

     Select center point of arc

  After entering the center point the first line of the prompt
  area changes to:

     Select second end point of arc

  As you move the cursor an arc is drawn from the first point to the
  current cursor position around the given center point in a counter-
  clockwise direction.  This represents the arc which would be added 
  to the drawing if the current cursor position is used for the 
  second end point.  When the second end point is specified an arc 
  with the designated start and end points is added to the drawing.  
  It is displayed using the current line properties in affect.

  The program continues to prompt you for the first point of an arc.
  If you wish to draw another arc, you can enter it at this point.

  To end arc input, select another operation from the main menu 
  (except those on the "Options" menu).  You can also end arc input
  by clicking the right mouse button (or press F2) and select "End" 
  from the dialog box which appears.

  See the section on "Specifying Positions" for more information on
  entering the arc points.  See the section on "Line Properties" for 
  more information on the different types of arcs which can be drawn.

  Circles
  Circles are drawn by specifying their center point and a point
  anywhere on the circle.

                      Figure 13 - Circle Input

  To Draw a circle all you have to do is select "Circle" from the 
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  "Draw" pull down menu or you can press Ctrl+I.  The prompt area 
  will display:

     Select center point of circle
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  After entering the center point the first line of the prompt area 
  changes to:

     Select point on circle

  As you move the cursor, a circle is drawn around the center point 
  and through the current cursor position.  This represents the
  circle which would be added to the drawing if the current cursor 
  position was used.  When the point on the circle is specified, a 
  circle with the designated center and circumference point is added 
  to the drawing.  It is displayed using the current line properties 
  in affect.

  The program continues to prompt you for the center point of the
  next circle.  If you wish to draw another circle, you can enter it 
  at this point.
 
  To end circle input, select another operation from the main menu 
  (except those on the "Options" menu).  You can also end circle 
  input by clicking the right mouse button (or press F2) and select
  "End" from the dialog box which appears.

  See the section on "Specifying Positions" for more information on
  entering the circle points.  See the section on "Line Properties" 
  for more information on the different types of circles which can be
  drawn.

  Points
  Points are drawn by specifying their position.

  To Draw a point all you have to do is select "Point" from the 
  "Draw" pull down menu or you can press Ctrl+P.  The prompt area 
  will display:

     Select point position
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  When a position is specified, a point is drawn using the current
  point properties in affect.

  The program continues to prompt you for a point position.  If you  
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  wish to draw more points you can do so at this time.

  To end point input, select another operation from the main menu 
  (except those on the "Options" menu).  You can also end point input
  by clicking the right mouse button (or press F2) and select "End" 
  from the dialog box which appears.

  See the section on "Specifying Positions" for more information on
  entering the point positions.  See the section on "Point 
  Properties" for more information on the different types of points 
  which can be drawn.

  Text
  Text is drawn by specifying the text alignment point and the
  desired text string.

                       Figure 14 - Text Input

  To Draw text, all you have to do is select "Text" from the "Draw" 
  pull down menu or you can press Ctrl+T.  The prompt area will 
  display:

     Select text alignment point
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  When a position is specified the text string input dialog is
  displayed.  
  
                   Figure 15 - Text Input Dialog

  Enter the desired text and select the "OK" button.  The text is 
  then displayed using the current text properties in affect.

  The program continues to prompt you for a text alignment position.
  If you want to enter more text strings do so at this point.

  To end text input, select another operation from the main menu 
  (except those on the "Options" menu).  You can also end text input
  by clicking the right mouse button (or press F2) and select "End" 
  from the dialog box which appears.

  See the section on "Specifying Positions" for more information on
  entering the text alignment points.  See the section on "Text 
  Properties" for more information on the different types of text   
  which can be drawn.
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  Symbol Libraries
  Any of the predefined GammaCAD symbols can be placed in the drawing
  by specifying their insertion point, angle and scale factor.

  To place a symbol in your drawing select "Symbol Libraries" from
  the "Draw" pull down menu.  A dialog is displayed that allows you
  to pick the type of symbol you want to draw.  Click on the library
  you desire and then click on the "OK" button.  The symbols in this
  library are displayed in the next dialog.  Click on the symbol you
  want and click on the "OK" button.  

  The prompt area will display:

     Select insert position
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  The base point of the symbol is aligned with the insertion point
  you enter.

  When a position is specified the rotation angle dialog is 
  displayed.  Enter the desired rotation angle for the symbol in
  degrees counter-clockwise and select the "OK" button.  Enter "0"
  for no rotation.  The scale dialog is displayed next.  Enter a
  value greater than 0.  A value less than 1 will cause the symbol
  to be displayed smaller than its actual size (e.g. 0.5 will cause
  it to be half size).  A value greater than 1 will cause it to be
  larger than actual size (e.g. 2. will cause it to be double size).

  After the angle and scale have been entered the program will draw
  the symbol using the parameters you specified.  It then prompts
  you for the insertion point again.  You can place any number of
  the same symbol in the drawing, each with its own angle and scale.
  To end symbol input select another operation from the main menu 
  (except those on the "Options" menu).  You can also end input
  by clicking the right mouse button (or press F2) and select "End" 
  from the dialog box which appears.

  See the section on "Specifying Positions" for more information on
  entering the symbol insertion points.  See the "Symbol" appendix
  for more information on the symbols supplied with GammaCAD (e.g. 
  the base point location, default dimensions, etc.).
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  Setting Line Properties
  All lines (including those used in arcs and circles) have the
  following three properties:

     1. Color.
     2. Type.
     3. Width.

  These properties can be specified before or during the input of a
  drawing element.  The selected properties remain in affect until
  another selection is made.  Whenever a line, arc or circle is 
  created, it is displayed using the current line color, type and 
  width.  They will always be displayed this way unless the 
  properties are changed.  See the section "Changing Drawing Element 
  Properties" for more information.

  Lines can only be displayed in solid colors.  In other words they
  cannot use dithered colors which use a pattern of different solid
  colors to produce the look of another color.  The number of solid
  colors which are available is dependent on the display device.

  To specify a line color, select "Line Color" from the "Options"
  menu.  To make a selection from the color input dialog, simply 
  click on the desired color (or highlight it using the arrow keys 
  and press the spacebar).  Then select the "OK" button.  If a 
  nonsolid color is selected the closest solid color is used instead.
  You must also be careful not to select colors which map to the 
  solid color white since they will not be visible on the white 
  background.

                   Figure 16 - Line Color Dialog

  To specify a line type, select "Line Type" from the "Options" menu.
  To select a line type, click on the desired type (or use the arrow
  keys).  The selected line type is displayed to the right.  Click
  on the "OK" button (or press Enter) to use the displayed line type.

                    Figure 17 - Line Type Dialog

  To specify a line width, select "Line Width" from the "Options"
  menu.  Enter the desired line width.  This value is specified in
  drawing units and its displayed width will vary depending on the
  current drawing area extents.  Specifying a width of 0 will cause
  the line to be drawn as thin as possible (1 pixel wide) no matter
  what the drawing area extents.

                   Figure 18 - Line Width Dialog
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  One important limitation is only solid lines can have a width of
  more than one pixel.  If a line type other than solid is selected 
  the current line width setting is ignored and the line is 
  drawn with the specified type but at a 0 width.

  Setting Text Properties
  Text strings have the following properties:

     1. Font name.
     2. Font style.
     3. Size.
     4. Effects.
     5. Color.
     6. Angle.
     7. Orientation.
     8. Justification.

  These properties can be specified before or during the input of a
  text element.  The selected properties remain in affect until
  another selection is made.  Whenever a text string is created it
  is displayed using the current text properties.  It will always be 
  displayed this way unless the properties are changed.  See the 
  section "Changing Drawing Element Properties" for more information.

  The font name is the main property affecting the appearance of a
  text string.  It determines how different characters in the
  string are drawn.  Windows comes with several built in fonts. 
  With version 3.1 of Windows TrueType fonts were introduced.  It
  is recommended you use these fonts exclusively.  The program
  defaults to allowing the selection of TrueType fonts only.  The
  TrueType fonts work much better with this program than some of the
  other Windows fonts.  

  To access the other fonts available to Windows click on the 
  "TrueType Fonts Only" item on the "Options" pull down.  This will 
  remove the check mark next to this item.  The next time you select 
  "Text Font" from the "Options" menu it will display all the fonts 
  available to Windows in the "Font Name" list.  When the check mark 
  is present to the left of "TrueType Fonts Only," only TrueType 
  fonts are listed by the "Text Font" option.  When there is no check
  mark present all fonts are listed.  The drawing may or may not 
  already contain fonts other than TrueType fonts.  This toggle does 
  not change existing text strings.

  The first 5 text properties are all specified using the "Text Font"
  selection on the "Options" menu.  To select the font name, click on
  the desired font name from the list.  You can scroll the list up
  and down by clicking on the scroll arrows if the list is longer
  than the number displayed.  To select a font style, click on the
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  desired style.  The font size, effects and color can be specified 
  in the same way.  A sample of the currently selected font is 
  displayed in the lower right of the dialog.  When you have input 
  the desired text properties click on the "OK" button.

                      Figure 19 - Font Dialog

  The parameters in this dialog are pretty self-explanatory with the
  possible exception of the "Size" parameter.  These sizes are in
  points.  A point is 1/72 of an inch.  This specifies the size of
  the text when plotted.  The size which appears on the display will 
  vary depending on the currently specified plot scale and the 
  current drawing area extents.  When you specify a text size, it is
  converted to the units you are using in the drawing area using the 
  currently specified plot scale and drawn with that size in the 
  drawing area.  For example, if you specified a 10 point font and 
  your current plot scale is 1 inch equals 100 drawing units then the
  height in drawing units for the text would be 13.9 (10/72 X 100).
  If the y extent of the drawing area is 100 then the text will be 
  13.9% as tall as the y extent of the drawing area.  If the drawing
  is zoomed so the y extent is 50 then the text will be 27.8%
  of the drawing area height.

                      Figure 20 - Text Example

  The text will always be plotted at a 10 point size (0.139") no
  matter what the plot scale or current drawing extents (unless the
  "Fit" plot option is used).

  The text angle specifies the rotation of the baseline of the text
  string in degrees counter-clockwise from the x axis.

                       Figure 21 - Text Angle

  The Windows raster fonts (i.e. Courier, Fixedsys, MS Sans Serif,
  MS Serif, Small Fonts, System and Terminal) will not rotate.

  The text orientation is not used by TrueType fonts so it is dimmed
  and unselectable on the menu if TrueType fonts only are specified.
  The only fonts currently supplied with Windows which support 
  orientation angles are the vector fonts: Modern, Script and Roman.
  The orientation angle is the rotation of the individual characters 
  of a text string in a counter-clockwise direction from the x-axis.
  The interaction between the baseline angle and the orientation 
  angle for the vector fonts can be quite difficult to understand.  
  The figure below shows some of the most common uses of baseline and
  orientation angles with vector fonts.

                    Figure 22 - Text Orientation

  There are a couple of drawbacks to using the vector fonts.  One is
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  the "Zoom Extents" command only uses the alignment point of vector 
  fonts in its calculations.  This means part or all of a text string
  which uses a vector font may lay outside the drawing area even 
  after a "Zoom Extents" command.  The second drawback is you must
  you must include the alignment point in your selection area in
  order to select a string using a vector font.

  The last property we will cover is text justification.  When you
  create a text element you are asked to input the alignment point.
  This point can represent different positions within the string
  depending on the current text justification setting.  The text 
  justification is initially set to "Top" and "Left" when the program
  is first loaded.  To change this setting select "Text 
  Justification" from the "Options" menu.  The text justification 
  dialog allows you to specify one of three horizontal justification 
  points (Left, Center and Right) and one of three vertical 
  justification points (Top, Baseline and Bottom).  To select one 
  click on its radio button and click on "OK".  

               Figure 23 - Text Justification Dialog
  
  The figure below shows all of the possible text justification 
  points.

                   Figure 24 - Text Justification

  The following table summarizes the capabilities of the fonts which
  come with Windows.

                  True                  Scal-  Rotat.  Orient.  Fixed
  Font            Type  Vector  Raster  able   Angles  Angles   Pitch
  Arial             X      X              X       X
  Courier New       X      X              X       X               X
  Symbol            X      X              X       X
  Times New Roman   X      X              X       X
  Wingdings         X      X              X       X
  Modern                   X              X       X       X
  Script                   X              X       X       X
  Roman                    X              X       X       X
  Fixedsys                         X                              X
  MS Sans Serif                    X
  MS Serif                         X
  Small Fonts                      X
  System                           X
  Terminal                         X                              X

                     TABLE 2 - Font Information

  A check mark for a font in the TrueType, Vector or Raster column 
  indicates what type of font it is.  A check in any of the following
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  columns means that feature is supported by the font.  The vector 
  fonts are scalable which means they can be increased or decreased 
  to any size.  Raster fonts come in discrete sizes.  Fixed pitch 
  fonts have a constant character width.

  Most of these fonts also support the regular, bold, italic and
  bold italic font styles.  They all support the underline and
  strikeout effects as well as color.

  Setting Point Properties
  Points have the following three properties:
     1. Color.
     2. Type.
     3. Size.
  These properties can be specified before or during the input of a
  point element.  The selected properties remain in affect until
  another selection is made.  Whenever a point is created, it is
  displayed using the current point color, type and size.  The point
  will always be displayed this way unless its properties are 
  changed.  See the section "Changing Drawing Element Properties" for
  more information.

  Points can only be displayed in solid colors.  In other words, they
  cannot use dithered colors which use a pattern of different solid
  colors to produce the look of another color.  The number of solid
  colors available is dependent on the display device.

  To specify a point color, select "Point Color" from the "Options"
  menu.  To make a selection from the color input dialog simply click
  on the desired color (or highlight it using the arrow keys and
  press the spacebar).  Then select the "OK" button.  If a nonsolid 
  color is selected the closest solid color is used instead.  You
  must also be careful not to select colors which map to the solid
  color white since they will not be visible on the white background.

                   Figure 25 - Point Color Dialog

  To specify a point type, select "Point Type" from the "Options" 
  menu.  To select a point type click on the desired type (or use the
  arrow keys).  The selected type is displayed to the right.  Click
  on the "OK" button (or press Enter) to use the displayed type.

                   Figure 26 - Point Type Dialog

  To specify a point size, select "Point Size" from the "Options"
  menu.  Enter the desired point size.  This value is specified in
  drawing units and its displayed size will vary depending on the
  current drawing area extents.

                   Figure 27 - Point Size Dialog
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  Saving The Drawing
  There are 2 commands for saving the drawing, "Save" and "Save As",
  both are on the "File" pull down menu.  The "Save As" command
  allows you to specify a file name.  Once a file name has been 
  specified for a drawing, you save it to the same file by selecting 
  "Save" or by pressing CTRL+S.  There are no further prompts when 
  using the "Save" command.  The "Save" option is dimmed and 
  unselectable until a file name has been specified for the drawing 
  with the "Save As" option.  
  
  The "Save As" option brings up a file selection dialog box.  To
  specify a file name, select a drive from the drive list and a
  directory from the directories list.  Type in the name of the file 
  in the "File Name" box.  You do not have to specify an extension 
  for the file name.  If you do not specify one, the extension ".GC1"
  will be appended to the name you enter.  It is recommended you use 
  a ".GC1" extension on all your drawing files so they will appear in
  the list of file names in the file selection dialog.  If you enter 
  an existing file name, the program will warn you and ask if you 
  want to replace it.  Selecting "Yes" will completely replace the 
  contents of the file with the current drawing.  The previous 
  drawing will be lost.  The file name dialog will not allow you to 
  enter an invalid path or file name.  When the desired drive, path 
  and file name have been entered, select the "OK" button and the 
  current drawing will be saved to the given file.

                     Figure 28 - Save As Dialog

  When a drawing is saved all the undo levels are removed.  This
  means previous operations cannot be undone after a save has been 
  performed.  This is done to free up the memory used by the undo 
  feature.

  Opening An Existing Drawing     
  If you want to edit a drawing created previously, select the "Open"
  command from the "File" menu.  This brings up the file selection 
  dialog.  Select the proper drive and directory from the drive and 
  directory lists and select one of the files from the file name 
  list and click on the "OK" button.  The drawing in the given file 
  will be displayed in the drawing area.  You must select an existing
  file with this option.  You can now edit the elements in the 
  displayed drawing or add more elements if desired.

                      Figure 29 - Open Dialog
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  If you select the "Open" item from the "File" menu and the drawing
  you are currently working on has not been saved, a message box will
  appear and ask if you want to save the current drawing. If "No" is
  selected, any changes made to the current drawing will be lost.  
  Selecting "Cancel," ends the "Open" command and returns you to the 
  current drawing.  If you select "Yes," the drawing will be saved to
  the file name you specified previously.  If no previous name was 
  specified, you will be prompted for a name.  After saving the file,
  the file open dialog will be displayed.

                Figure 30 - File Exists Message Box

  Creating A New Drawing     
  If you are currently editing a drawing and would like to start a
  new drawing, select "New" from the "File" menu.  The contents of
  the drawing area is cleared and you are placed in a blank drawing.

  If you select the "New" item from the "File" menu and the drawing
  you are currently working on has not been saved, a message box will
  appear and ask if you want to save the current drawing. If "No" is
  selected, any changes made to the current drawing will be lost.  
  Selecting "Cancel," ends the "New" command and returns you to the 
  current drawing.  If you select "Yes," the drawing will be saved to
  the file name you specified previously.  If no previous name was 
  specified, you will be prompted for a name.  After saving the file,
  you are placed in a new drawing.
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  Printing / Plotting The Drawing     
  The drawing may be plotted to any print device using the  
  "Print/Plot" command on the "File" menu.  A print device is added 
  to Windows using the Control Panel and it can be a printer or a 
  plotter.  When "Print/Plot" is selected, a plot scale dialog is 
  displayed.  The drawing may be plotted to scale or the current 
  drawing area can be "fit" to the available plot area on the output
  device.

                   Figure 31 - Plot Scale Dialog

  To fit the drawing area to the plot page click on the "Fit plot to 
  page" check box so the box is checked and then select the "OK" 
  button.  The current drawing area will be sent to the current print
  device and displayed as large as possible on the page.  The scale 
  of the drawing will be adjusted to allow the drawing area to be 
  displayed as large as possible.  The plot scale value set in the 
  dialog is ignored.

  To plot the drawing to scale, enter the desired scale in the dialog
  and select the "OK" button.  The drawing will be plotted at the 
  scale specified.  The "Fit Plot to page" check box must be 
  unchecked for this plot method.

  For both of these plot methods, the origin of the plot is set to
  the lower-left corner of the drawing area.  This means you must
  zoom and pan the drawing using the "View" menu to get the desired
  plot origin point at the lower left of the drawing area.  The 
  figure below demonstrates how the drawing area is mapped to the 
  plot page using these two methods.

              Figure 32 - Drawing To Plot Page Mapping

  When the "OK" button is pressed in the plot scale dialog, the print
  setup dialog is displayed.  To use the current setup parameters
  select the "OK" button.  See the next section "Print Setup" for
  more information on specifying printer parameters.

  After the "OK" button is pressed in the print setup dialog, another
  dialog box is displayed.  This dialog is displayed while the plot 
  is being created.  This dialog has one button, "Cancel".  Pressing 
  this button will cause the plot operation to be canceled.  If this 
  button is not selected the plot is created and sent to the Print 
  Manager.  For more information on the Print Manager see your 
  Windows manual.

                     Figure 33 - Cancel Dialog

  If you have configured Windows to use "English" units, your plot 
  scale specifies the number of drawing units per inch.  If you have 
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  configured Windows to use "Metric" units, the plot scale specifies 
  the number of drawing units per centimeter.  The "International" 
  option on the Windows Control Panel is used to set this parameter.
  Select the desired units from the "Measurement" field.  See your 
  Windows manual for more information.

  This program does not care what units you use in the drawing.  They
  can be anything.  The plot scale is used to relate the drawing
  units to inches (or centimeters) on the printer/plotter.

  Print Setup
  When "Print Setup" or "Print/Plot" is selected from the "File" menu
  the program displays the print setup dialog.  The "Print Setup"
  option allows you to set print parameters without plotting the     
  drawing.  The "Print/Plot" option brings up the setup dialog to
  allow you to change parameters before you plot the drawing.

                     Figure 34 - Print Setup Dialog

  This dialog allows you to select the desired printer for output and
  change options for the selected printer.  Not all printers support
  all options.  An option may be dimmed and unselectable if it is not
  available.  The print setup dialog contains a "Setup" button
  allowing you to set options specific to the currently selected 
  printer.  If you select this button you can change these options
  and when you select "OK" you are returned the to print setup 
  dialog.  Selecting "Cancel" ignores any changes you made.

  When you have finished making changes in the print setup dialog 
  select the "OK" button.  This completes the command if you 
  initially selected "Print Setup" from the pull down menu.  If you
  selected "Print/Plot" the program proceeds to create the printout.
  Selecting "Cancel" ends either command ignoring any changes you
  have made and no printout is created.
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  The view options are used to display different parts of your
  drawing.  They can be used to look at an area in detail or the
  drawing as a whole.  They do not change the actual coordinates
  or dimensions of the drawing elements.  They only allow you to
  view them in different ways.

  Zooming In On An Area Of The Drawing
  To see an area of the drawing in more detail, use the "Zoom
  Window" option on the "View" menu.  With this option you input
  a rectangular area within the display area and that area
  is enlarged to cover the entire display area.

                      Figure 35 - Zoom Window

  When you select "Zoom Window" from the "View" menu or press Ctrl+W
  the prompt area changes to:

     Select first corner of window
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  You may select any corner of the area you want to enlarge.  Once
  you have selected the first corner the prompt changes to:

     Select second point

  As you move the cursor, a box is drawn from the first point entered
  to the current cursor position.  This box represents the area which
  will be enlarged if the current cursor position is selected.  When 
  the second point is selected, the input area is enlarged as much as
  possible while still displaying the entire area selected.  If the 
  area you input is of a different shape than the shape of the 
  current drawing area, you may get some elements in the drawing area
  which were not in the area selected and the enlargement may not be 
  as much as expected.  Keep in mind, this command displays the 
  entire area selected at a minimum.  It will display more in one 
  direction if necessary to display the entire area in the other 
  direction.

              Figure 36 - Effects Of Zoom Window Shape

  Displaying All The Elements In The Drawing
  To display all the elements in the drawing within the drawing area,
  use the "Zoom Extents" command on the "View" menu.  This command
  will display all the drawing elements as large as possible within
  the drawing area.
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  Restoring A Previous View
  To display the previous view, select "Zoom Previous" from the 
  "View" menu or press Ctrl+R.  If there is no previous view to 
  restore, the "Zoom Previous" option is dimmed and unselectable.  Up
  to 10 previous views are saved and can be restored.

  Zooming In And Out
  The drawing may be zoomed in (enlarged) and out (shrunk) using the 
  "Zoom Factor" option on the "View" menu.  When you select this
  option a dialog box appears which prompts you for a zoom factor.
  To zoom in, specify a number greater than 1.  To zoom out, specify
  a number greater than zero but less than one.  For example, 
  specifying a value of 2 causes the drawing to be displayed at twice
  its current size.  Specifying a value of 0.5 causes the drawing to
  be displayed at half its current size.

  The current center point of the display area remains in the center
  after the zoom.

                      Figure 37 - Zoom Factor

  Moving The Drawing Right/Left/Up/Down In The Drawing Area
  The drawing elements may be moved right, left, up and down in the 
  drawing area while still maintaining the current zoom factor by
  using the "Pan" option on the "View" menu.  Selecting this option
  changes the prompt area to:

     Select first point to define the displacement
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  Pick a position within the drawing area you want to move elsewhere
  The first line of the prompt area changes to:

     Select second point

  Pick the position you would like the first point to be moved to
  within the drawing.  The drawing area will be redrawn with the 
  drawing elements shifted by the specified amount.

                          Figure 38 - Pan
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  Redraw: Cleaning Up The Drawing Area
  During the course of drawing and editing you may get extra tic  
  marks and such within the drawing area which are not actually part
  of the drawing.  To erase the drawing area and redraw only the 
  elements actually in the drawing, select "Redraw" from the "View"
  menu.
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  Selecting Drawing Elements
  All of the options on the "Edit" menu within the block starting
  with "Select" (excluding "Paste") require one or more drawing 
  elements be selected first.  They are dimmed and unselectable 
  if no drawing elements are selected.  To select elements, pick the 
  "Select" option off of the "Edit" menu.  The prompt area will 
  display:

     Select first corner of selection area
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  When selecting drawing elements you input opposite corners of a
  rectangular area and all elements falling within this area or
  cross it will be selected.  You may pick any corner of the area
  first.  After selecting the first corner the first line of the 
  prompt area becomes:

     Select second point

  Now you must enter the diagonally opposite corner of the selection
  area rectangle.  As you move the cursor, a box is displayed with
  one corner at your first selection point and the opposite corner
  at your current cursor position.  This represents the area which
  would be used for the selection if the current cursor position was
  used for the second point.  

                   Figure 39 - Selecting Elements

  When the second point is selected, the program displays the
  elements which are inside or cross the selection area in the 
  selection color.  These are the selected elements.  The selection
  color is initially set to light gray but it can be changed using
  the "Selection Set Color" item on the "Options" menu.

  Moving Drawing Elements
  Elements within the drawing can be moved from one position to
  another by using a combination of the "Cut" and "Paste" options on
  the "Edit" menu.  To move a drawing element, first select the
  element(s) you want to move.  See the section on selecting drawing
  elements for information on how to do this.

  Once the desired elements have been selected pick the "Cut"
  command off of the "Edit" menu.  The prompt area will display:

     Select cut reference point
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

_____________________________________________________________________
                                33 



                          EDIT OPERATIONS
_____________________________________________________________________

  The point you pick will correspond to the alignment point you
  select when you perform the paste operation.  Once the reference
  point has been entered the selected elements will be erased from
  the display and deleted from the drawing.  
  
  Next select "Paste" from the "Edit" menu.  The prompt line will 
  display:

     Select paste alignment point
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  As mentioned previously, the paste alignment point corresponds to 
  the cut reference point.   When an alignment point is selected, the
  elements cut previously are drawn at the new position and added to
  the drawing.

                Figure 40 - Moving Drawing Elements

  The elements may be pasted as many times as desired at any
  location in the drawing area.  To end the paste command select
  another command from the menu or click the right mouse button and
  select "End" from the dialog.

  The cut operation copies the selected elements to the Windows
  Clipboard.  The paste operation retrieves them from the Clipboard
  and inserts them into the drawing.  The "Paste" option is dimmed
  and unselectable if no data has been cut or copied to the 
  clipboard.  

  This program uses a private data format when storing data in the 
  clipboard.  This is because none of the currently defined clipboard
  formats provide enough information for drawing elements to be cut
  or copied to the clipboard and then pasted back without loss of 
  information.  This means drawing elements cut or copied to the
  clipboard cannot be pasted into other programs unless they 
  specifically support the GammaCAD clipboard format.  Also, the 
  GammaCAD "Paste" option cannot paste things from the clipboard 
  which were cut/copied by another program.  See the "Copy Bitmap" 
  command for information on how to copy a bitmap from GammaCAD to 
  another program.  The appendix on the "Clipboard Data Format" 
  contains a definition of the GammaCAD clipboard format.

  Copying Drawing Elements Within The Same Drawing
  Elements within the drawing can be copied to another position by
  using a combination of the "Copy" and "Paste" options on the "Edit"
  menu.  To copy a drawing element first select the element(s) you 
  want to move.  See the section on selecting drawing elements for 
  information on how to do this.
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  Once the desired elements have been selected pick the "Copy"
  command off of the "Edit" menu.  The prompt are will display:

     Select copy reference point
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  The point you pick will correspond to the alignment point you
  select when you perform the paste operation.  Unlike the "Cut"  
  command, the "Copy" command does not erase the selected elements.
  They remain in the drawing.
  
  Next select "Paste" from the "Edit" menu.  The prompt line will 
  display:

     Select paste alignment point
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  As mentioned previously, the paste alignment point corresponds to 
  the copy reference point.   When an alignment point is selected, 
  the elements copied previously are drawn at the new position and 
  added to the drawing.

                Figure 41 - Copying Drawing Elements

  The elements may be pasted as many times as desired at any
  location in the drawing area.  To end the paste command, select
  another command from the menu or click the right mouse button and
  select "End" from the dialog.

  This program uses a private data format when storing data in the 
  clipboard.  This is because none of the currently defined clipboard
  formats provide enough information for drawing elements to be cut
  or copied to the clipboard and then pasted back without loss of 
  information.  This means drawing elements cut or copied to the
  clipboard cannot be pasted into other programs unless they 
  specifically support the GammaCAD clipboard format.  Also, the 
  GammaCAD "Paste" option cannot paste things from the clipboard 
  which were cut/copied by another program.  See the "Copy Bitmap" 
  command for information on how to copy a bitmap from GammaCAD to 
  another program.  The appendix on the "Clipboard Data Format" 
  contains a definition of the GammaCAD clipboard format.

  Moving / Copying Drawing Elements Between Drawings
  Drawing elements can be moved and copied between drawings as well
  as within the same drawing.  To do this perform the cut or copy
  operation just as you do for moving/copying elements within the 
  same drawing.  Then load another copy of the GammaCAD program 
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  and bring up the drawing you wish to move/copy the elements to.  
  Next paste the elements into that drawing.  Alternatively, instead 
  of loading another copy of GammaCAD you can open the drawing you 
  want to paste into within the current instance of the program and 
  paste the elements.  The first method requires more memory but 
  is much more convenient, especially if you need to perform multiple
  copy operations.

       Figure 42 - Copying Drawing Elements Between Drawings

  Deleting Drawing Elements
  To delete drawing elements, first select the elements to delete 
  (see the section on selecting elements).  Then select "Delete"
  from the "Edit" menu.  The selected elements are deleted from the
  drawing and erased from the drawing area.

  Rotating Drawing Elements
  To rotate drawing element, first select the elements to rotate 
  (see the section on selecting elements).  Then select "Rotate"
  from the "Edit" menu.  The prompt area will display:

     Select rotation center point
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  After picking a position, a dialog is displayed which allows you to
  enter the desired rotation angle.  Enter the angle in degrees 
  counter-clockwise and click on the "OK" button.  The selected 
  elements will be rotated about the given center point by the given 
  angle.

               Figure 43 - Rotating Drawing Elements

  The program continues to prompt you for a rotation center point.
  You can pick another point and rotate the elements again or end  
  the command by clicking the right mouse button and selecting "End"
  from the dialog.

  Scaling Drawing Elements
  This command is used to increase or decrease the size of drawing
  elements.

  To scale drawing elements, first select the elements to scale 
  (see the section on selecting elements).  Then select "Scale"
  from the "Edit" menu.  The prompt area will display:
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     Select scale reference point
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  After picking a position, a dialog is displayed which allows you to
  enter the desired scale factor.  A factor greater than one 
  increases the size of the selected elements and a factor greater 
  than 0 but less than 1 reduces the size of the elements.  For 
  example a scale factor of 2 doubles the size of the elements.  A 
  scale factor of 0.5 halves the size of the elements.  When the 

  desired scale factor has been input, click on the "OK" button.  The
  selected elements will be scaled about the given reference point by
  the input scale factor.

                Figure 44 - Scaling Drawing Elements

  The program continues to prompt you for a scale reference point.
  You can pick another point and scale the elements again or end  
  the command by clicking the right mouse button and selecting "End"
  from the dialog.

  Changing Drawing Element Properties
  To change the properties of drawing elements, first select the 
  elements to change.  Then select "Change" from the "Edit" menu or 
  press Ctrl+H.  This will bring up a dialog which allows you to 
  select what property to change.  You can only change one property 
  at a time.  To select a property, click on its radio button and 
  then click on the "OK" button.

                     Figure 45 - Change Dialog

  The program will bring up a dialog which allows you to specify the 
  new property.  These dialogs are the same ones used in the 
  corresponding selections on the "Options" menu.  See the 
  appropriate section under "Drawing Element Properties" in this
  manual for more information on using these dialogs.

  When the new property is specified, the selected elements are
  changed.  You will have to clear the selection set (see that
  section) in order to see color changes since the current selection
  set is always drawn in the selection set color.

  Listing Drawing Elements
  With the "List" option on the "Edit" pull down menu you can
  display the properties for selected elements.  First select the
  elements to list and then pick "List" from the "Edit" menu.
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  A dialog with the properties for the first element in the
  selection set is displayed.  Select "OK" to display the next
  element's properties or "Cancel" to quit.

                      Figure 46 - List Dialog

  Clearing The Current Selection
  To clear the current selection and display the selected drawing
  elements in their actual color, select "Clear Selection" from the
  "Edit" menu.

  Undoing Changes To The Drawing 
  The "Undo" option on the "Edit" pull down menu can be used to undo
  edit operations.  If there are no edit operations which can be
  undone, the "Undo" option is dimmed and unselectable.

  All of the commands on the "Edit" menu can be undone with the   
  exception of "Select", "Copy", "List" and "Clear Selection".  You 
  also cannot undo an "Undo" command.  The commands on the "Draw" 
  menu can also all be undone.

  Copy Bitmap - Placing Drawings In Other Programs
  The "Copy Bitmap" option on the "Edit" pull down menu allows you to
  select a rectangular area in the drawing area to be copied to the 
  Windows clipboard as a bitmap.  The bitmap can be pasted into any 
  program which allows you to paste a bitmap.             

  To copy a bitmap to the clipboard select the "Copy Bitmap" option 
  off of the "Edit" menu.  The prompt area will display:

     Select first corner of bitmap area
     MOUSE: position cursor, press left button. Right button for...
     KEYBOARD: position with arrow keys, press Enter. F2 for...

  When selecting the area you input opposite corners of a rectangular
  area.  You may pick any corner of the area first.  After selecting 
  the first corner, the first line of the prompt area becomes:

     Select second point

  Now you must enter the diagonally opposite corner of the bitmap
  area rectangle.  As you move the cursor, a box is displayed with
  one corner at your first selection point and the opposite corner
  at your current cursor position.  This represents the area which
  would be used for the selection if the current cursor position was
  used for the second point.  
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  When the second point is selected, the program copies the selected
  area to the clipboard as a bitmap.  To paste it into another 
  program, change to that program and select "Paste" from its menu.  
  Not all programs will paste a bitmap.  See the documentation for 
  the program you want to paste a drawing into for more information.

  GammaCAD will not paste a bitmap from the clipboard.  The GammaCAD
  "Paste" option will only paste drawing elements placed in the 
  clipboard using the "Copy" or "Cut" options on the GammaCAD "Edit" 
  menu.

  Modifying Symbols
  The drawing elements making up a symbol are treated as a unit once
  a symbol is inserted into a drawing.  When you select one drawing
  element in a symbol, the entire symbol is selected.  This is due to
  the fact the elements making up a symbol are stored in the drawing 
  only once.  Each insertion of a symbol only contains the symbol 
  name, position, scale and rotation.

  The "Change" command on the "Edit" menu has no affect on symbols.
  To change a symbol you must load the symbol file into GammaCAD
  using the "Open" command on the "File" menu.  Symbol files are
  exactly the same as other drawing files.  They are given a .SYM
  extension merely as a file keeping aid.  From the "Open" dialog
  click on the arrow button to the right of the "List Files of Type"
  field (or press Alt+T and then the down arrow key).  Select "Symbol
  File (*.SYM)" from the list.  The dialog will list the symbol files
  in the current directory.  Select the desired symbol from the list.
  You may need to change to the GammaCAD directory.

  Once the symbol file is loaded you can use any of the program 
  commands to add, change or delete drawing elements.  Select the 
  "Save" command from the "File" menu when you are done editing the
  symbol.  The next time you insert the symbol into a new drawing
  the new symbol will be used.  The changes will not affect drawings
  created previously containing the symbol.

  See the "Symbol" appendix to determine which symbol files 
  correspond to which symbols.
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  Changing The Selection Set Color
  The program displays selected elements in a certain color.  To
  change the color, pick the "Selection Set Color" item off of the 
  "Options" menu.  This will bring up the color selection dialog. 
  Select the new color from this menu and click on the "OK" button.
  The selection set will now be displayed in that color.

  Setting The Plot Scale
  The "Plot Scale" selection on the "Options" menu allows you to set
  a plot scale.  This selection brings up a plot scale dialog.  This
  dialog is also displayed when "Plot" is selected from the "File"
  menu.  There are 2 differences between them, however.  The "Fit
  plot to page" is dimmed and unselectable in the "Options" version 
  of the plot scale dialog.  This version also does not try to plot 
  the drawing when the "OK" button is selected.  This option is 
  placed here so a plot scale can be set without plotting the 
  drawing.  Plot scale affects the size of the text in the drawing 
  area.  This option allows the plot scale to be changed if the text 
  is too small or large.  See the section on text properties for a 
  further explanation of text size and plot scale.

  Changing The Cursor Step Size
  The cursor moves a certain number of pixels on the display when an
  arrow key is pressed.  The cursor increment or step size specifies
  how many pixels it moves.  This value is initially set to 5. 
  Larger values cause the cursor to move more quickly across the
  display but make it more difficult to position the cursor at
  desired coordinates.  Smaller values have the opposite effect.

  To change this value select "Cursor Increment" off of the "Options"
  menu.  Enter the desired cursor increment (greater than 0) and
  click on the "OK" button.  The cursor will then move by that number
  of pixels when an arrow key is pressed and the cursor is in the 
  drawing area.
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  Getting Help On-Line
  To get help on different aspects of this program using the Windows
  help facility, select "Help" from the "Help" pull down menu or 
  press F1.  See your Windows manual for more information on using 
  this help facility.

  Exiting The Program
  To exit the program, simply select "Exit" from the "File" menu.

  If you select the "Exit" item from the "File" menu and the drawing
  you are currently working on has not been saved, a message box will
  appear and ask if you want to save the current drawing. If "No" is
  selected, any changes made to the current drawing will be lost.  
  Selecting "Cancel," ends the "Exit" command and returns you to the 
  current drawing.  If you select "Yes," the drawing will be saved to
  the file name you specified previously.  If no previous name was 
  specified, you will be prompted for a name.  After saving the file,
  the program will exit.
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     Quick Key Summary
  Quick keys can be used as a short-cut instead of selecting the
  corresponding options off of the menu.  The table below summarizes
  the quick keys which can be used in this program and what they do.

  Key      Description
  Ctrl+S   Save the drawing to the current file.
  Ctrl+Z   Undo the last edit operation or draw operation.
  Ctrl+E   Select drawing elements.
  Ctrl+X   Cut the current selection to the clipboard.
  Ctrl+C   Copy the current selection to the clipboard.
  Ctrl+V   Paste the contents of the clipboard.
  Ctrl+H   Change properties of the current selection.
  Ctrl+L   Draw a line.
  Ctrl+A   Draw an arc.
  Ctrl+I   Draw a circle.
  Ctrl+P   Draw a point.
  Ctrl+T   Draw a text string.
  Ctrl+W   Zoom window.
  Ctrl+R   Zoom previous.
  F2       Brings up the coordinate input dialog when the program is
           prompting for a position.
  F1       Brings up the Windows help facility.

  Clipboard Format
  The clipboard data used by this program is stored in binary format.
  It is registered with Windows using the following text string:

     GCAD Vector Graphics

  The first integer gives the number of font table entries.  This is
  followed by 54 bytes for each font table entry (font id, font index
  and LOGFONT structure).  Following the font table entries is the
  name of the first figure.  If this name is "MAIN" then it is the
  main figure, otherwise it is an inserted figure (symbol).  Next 
  comes the xy coordinates of the user selected reference point for 
  "MAIN" and the base point for inserted figures.  Following this are
  the actual drawing elements for the figure.  They start with a type
  identifier and are followed by a specific number of parameters 
  depending on the type.  The drawing elements can be in any order.  
  They are terminated by a type value of 0.  Following this is the 
  name of the next figure, its xy position and then its elements.  A 
  zero length figure name marks the end of the clipboard data.
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  Type     Bytes  Description
  int         2   Number of fonts which follow.
  int         2   Type. Font table entry = 13.  
  int         2   Font index.
  LOGFONT    50   Logical font structure defined in Windows SDK.

* char        9   Name of figure.  "MAIN" is the main figure and all 
                  others are inserted figures (symbols).  This is a
                  NULL (0x00) terminated string.
  double      8   X-coordinate of user selected reference point for
                  the "MAIN" figure and the base point for an 
                  inserted figure.
  double      8   Y-coordinate.

  int         2   Type.  Line = 1.
  int         2   Reserved.
  long        4   RGB color value.
  double      8   X-coordinate of first end.
  double      8   Y-coordinate of first end.
  int         2   Line type.  Uses the standard Windows GDI values.
  double      8   Line width.
  double      8   X-coordinate of second end.
  double      8   Y-coordinate of second end.

  int         2   Type.  Arc = 2.
  int         2   Reserved.
  long        4   RGB color value.
  double      8   X-coordinate of center.
  double      8   Y-coordinate of center.
  int         2   Line type.  Uses the standard Windows GDI values.
  double      8   Line width.
  double      8   Start angle (radians).
  double      8   End angle (radians).
  double      8   Radius.

* int         2   Type.  Insert = 3.
  int         2   Reserved.
  long        4   RGB color value.  Not used.
  double      8   X-coordinate of insertion point.
  double      8   Y-coordinate of insertion point.
  char        9   Symbol name.  This is an insertion of the figure
                  with this name.
  double      8   Rotation angle (radians).
  double      8   Scale factor.
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  Type     Bytes  Description
  int         2   Type.  Circle = 6.
  int         2   Reserved.
  long        4   RGB color value.
  double      8   X-coordinate of center.
  double      8   Y-coordinate of center.
  int         2   Line type.  Uses the standard Windows GDI values.
  double      8   Line width.
  double      8   Radius.

  int         2   Type.  Point = 7.
  int         2   Reserved.
  long        4   RGB color value.
  double      8   X-coordinate of point.
  double      8   Y-coordinate of point.
  int         2   Point type.  1 = plus, 2 = x, 3 = circle, 4 = box.
  double      8   Size.

  int         2   Type.  Text = 8.
  int         2   Reserved.
  long        4   RGB color value.
  double      8   X-coordinate of text alignment point.
  double      8   Y-coordinate of text alignment point.
  int         2   Font index.  Correlates to the font table index.
  double      8   Height (inches).
  double      8   Baseline angle (radians).
  double      8   Orientation angle (radians).
  int         2   Justification.  Standard Windows GDI value.
  int         2   Length of text string.
  char        ?   The actual text string.  Length is given above.

  int         2   Type.  End of data = 0.

* New to version 1.10.

  Memory Management
  This program allocates memory for the drawing elements in blocks.
  The default block size is 50k and the default number of blocks is
  100.  This allows a potential drawing size of approximately 5M.
  Both of these parameters can be changed by inputing different
  values on the command line.  To do this, simply add the desired
  block size and then the number of blocks at the end of the command
  line.  There must be a space between the end of the command line
  and the block size and also a space between the block size and the
  number of blocks.  For example:

     c:\gcad\gcad 64000 200
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  would set the block size to 64000 bytes and the number of blocks to
  200.  You must specify both parameters.  You cannot just specify a 
  block size.  The block size must be between 1024 and 64511.  The 
  number of blocks must be greater than 0 and less than 64511.

  When the program needs another memory block and cannot allocate it,
  you receive the message, "Out of memory. Save your drawing".       
  Saving the drawing will free the memory used by the undo feature.
  It also deletes the current selection and frees the memory used by 
  it.  Then it compacts the drawing in memory to remove any wasted
  space due to deleted elements.  If you get another out of memory
  message immediately after saving your drawing then your drawing
  cannot be made any larger without providing more memory to the
  program.  Close some other applications or increase your available
  disk swap space in enhanced mode.  If you are using a system with
  very little available memory you may need to decrease the block 
  size parameter to make more efficient use of memory.

  If you get the message, "Memory table overflow" you may need to 
  increase the number of blocks parameter on the command line.

  Symbols
  The following table lists the details associated with each symbol
  available in GammaCAD.

     Group        Name            File            Size   Base Point
     Polygons     Triangle        triangle         1x1   Center
     Polygons     Square          square           1x1   Center
     Polygons     Pentagon        pentagon         1x1   Center
     Polygons     Hexagon         hexagon          1x1   Center
     Polygons     Heptagon        heptagon         1x1   Center
     Polygons     Octagon         octagon          1x1   Center
     Floor Plans  Tub             tub60x32     5.0x2.6   Lower-left
     Floor Plans  Door            door24       2.0x2.0   Lower-left
     Floor Plans  Window          window48     4.0x0.5   Lower-left
     Floor Plans  Toilet          toilet       1.8x2.3   Lower-left
     Floor Plans  Lavatory        lav36x22     3.0x1.8   Lower-left
     Furniture    Chair           chair1       2.8x2.7   Center
     Furniture    Chair (office)  chair2       2.4x1.6   Center
     Furniture    Couch           couch1       7.3x3.0   Center
     Furniture    Desk            dsk60x30     5.0x2.5   Center
     Furniture    Bed (Queen)     bedq         5.3x2.8   Center
     Landscaping  Car             car          .45x1.0   Lower-left
     Landscaping  Tree (plan)     tree1            1x1   Center
     Landscaping  Tree (profile)  tree2        0.5x1.0   Center
     Landscaping  Light           light1       0.3x1.0   Center
     Landscaping  Bush            bush1            1x1   Center
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     Group        Name            File            Size   Base Point
     Electronics  Resistor        resistor     1.0x0.2   Left-center
     Electronics  Capacitor       capacitr     1.0x0.6   Left-center
     Electronics  Inductor        inductor     1.0x.15   Left-center
     Electronics  Transistor      transist     .35x1.0   Left-center
     Electronics  Diode           diode        1.0x1.0   Left-center
     Electronics  Ground          ground       1.0x1.0   Top-center
     Networks     PC (desktop)    pc_desk      1.8x2.0   Lower-left
     Networks     PC (tower)      pc_tower     2.2x2.0   Lower-left
     Networks     Mouse           mouse        0.3x0.8   Top-left
     Networks     Digitizer       digitizr         1x1   Lower-left
     Networks     Printer         printer      1.1x2.3   Lower-left
     Civil Eng.   North Arrow     n_arrow      0.1x1.0   Lower-left
     Civil Eng.   Scale           scale        1.0x0.1   Lower-left
     Civil Eng.   Manhole         man_hole         1x1   Center
     Civil Eng.   Light Pole      lt_pole          1x1   Center
     Civil Eng.   Storm Drain     st_drain         1x1   Center

  The "File" column lists the file which contains the symbol (add a
  ".SYM" extension).  The "Size" column gives the dimensions if the 
  symbol is inserted with a scale factor of one.  Some symbols are
  drawn to actual size while others have a dimension of one for x
  and/or y.  For these symbols enter a scale factor equal to the size
  you want the symbol in your drawing.  For example, to create a car 
  with a length of 10 in your drawing enter a scale factor of 10.  
  The "Base Point" column lists the point in the symbol which is
  aligned with the insertion point you pick in your drawing.

  Revision History
  The following changes were made from version 1.00 to 1.10.

   1. Symbol capability was added.
   2. Printer setup dialogs were added.
   3. The copy bitmap function was added.
   4. The install/setup program was added.
   5. The program name was changed from CAD Vantage to GammaCAD.
   6. The option on the plot scale dialog to reverse text angles on
      the printout was eliminated.  This option should no longer be
      required.
   7. Text justification was modified to produce better results on
      printers and plotters.  Applies to TrueType fonts only.
   8. The "Zoom Factor" command was changed to behave more like the
      other commands which use a scale factor.  A number less than
      1 decreases and greater than 1 increases the drawing size.
   9. Program now uses Windows 3.1 print calls.
  10. Text selection was improved.
  11. An error which occurred when zooming by a very small window was
      corrected.
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  12. The drawing file extension was changed from .DWG to .GC1 to
      avoid confusion with AutoCAD drawing files.
  13. The "Print/Plot" and "Save" commands no longer reset the
      current text font.
  14. More information is now given in the text list dialog.
  15. The default scale of a new drawing is now 1" = 1 drawing unit
      (1cm = 1 drawing unit if metric configured).
  16. The initial window in a new drawing is set to at least 8.5x11.
  17. Using the "Zoom Extents" command in an empty drawing used to
      set an invalid drawing window.  This was corrected.
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  Glossary
  CAD                   Computer Aided Design.
  Current Selection     All the drawing elements which have been     
                        selected using the "Select" command.       
  Cursor Increment      The number of pixels the cursor moves when a
                        keyboard arrow key is pressed.
  Cursor Step           Same as "Cursor Increment".
  Dialog Box            A windows pop up menu which contains input
                        fields, check boxes, buttons and so on.
  Drawing Area Extents  The range of coordinates displayed in the 
                        drawing area.
  Drawing Extents       The range of coordinates covered by all the
                        drawing elements.
  Drawing Element       One of the 5 basic parts of a drawing: lines,
                        arcs, circles, points and text.
  Drawing Units         The dimensions used in the drawing area.   
                        They can be anything (e.g. feet,meters,etc.)
  Font                  A particular style of text.
  K (Kilobyte)          1024 bytes of memory or disk space.
  M (Meg or Megabyte)   1024 K bytes of memory or disk space.
  Origin                The (0,0) point of an xy coordinate system.
  Pan                   To shift the view of the drawing within the
                        drawing area left, right, up or down.
  Plot Units            The dimensions used to specify sizes on the
                        plot (inches or centimeters).
  Quick Key             A short-cut key sequence which can be used 
                        instead of selecting a command from a menu.
  Raster                In this manual it denotes graphics defined
                        by a series of points as opposed to "Vector".
                        For example, a line is defined by a series of
                        points.
  Selected Elements     Same as "Current Selection".
  Selection Set         Same as "Current Selection".
  Text Angle            The rotation, counter-clockwise, of the
                        baseline of a text string.
  Text Justification    How the text is aligned.  For example, at the
                        left top corner.
  Text Orientation      The rotation, counter-clockwise, of the 
                        individual characters in a text string.
  Vector                In this manual it denotes graphics defined
                        by their end points as opposed to "Raster".
                        For example, a line is defined by 2 points.
  Zooming               Enlarging or decreasing the view of the
                        drawing.
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